Entah salah apa, bagaimana dan kapan hal ini terjadi, tiba-tiba wget mogok kerja di server FreeBSD saya. Setiap kali dijalankan selalu muncul error seperti dibawah ini:

# wget

/libexec/ld-elf.so.1: /lib/libc.so.7: version FBSD_1.1 required by wget not found

Saya cek dependensi wget berikut dengan library yang terkait dengannya, tidak ada masalah:

# ldd /usr/local/bin/wget
/usr/local/bin/wget:
libssl.so.7 => /usr/local/lib/libssl.so.7 (0x280cb000)
libcrypto.so.7 => /usr/local/lib/libcrypto.so.7 (0x28118000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2827a000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x28370000)
libidn.so.16 => /usr/local/lib/libidn.so.16 (0x28379000)
libc.so.7 => /lib/libc.so.7 (0x283a9000)

# ldd /libexec/ld-elf.so.1
/libexec/ld-elf.so.1:

# ldd /lib/libc.so.7
/lib/libc.so.7:

(more…)